Salesforce TLS changes & Chatter for SharePoint


Hi Everyone. Wanted to make my customers aware of a security change that Salesforce is beginning to phase-in that will impact the Chatter for SharePoint product. Effective March 4, 2017, Salesforce will remove support for TLS 1.0 protocol encryption (Sandboxes will be updated on June 25, 2016). Chatter for SharePoint currently uses TLS 1.0 to communicate with the Salesforce Chatter API. An update will be required to continue using the products after the TLS changes are implemented.

Affected Products:

  • Chatter For SharePoint 2010 (All versions prior to 2.5.1.0)
  • Chatter for SharePoint 2013/2016 (All versions prior to 2.5.1.0)

While both versions require an update to support TLS 1.1/1.2, the 2010 version will require additional changes due to lack of support for TLS 1.1 or higher in the .NET Framework version supported by SharePoint 2010. I expect both versions to be updated and supporting the newer protocol encryptions shortly.

For additional information about this change – please see the following article from Salesforce: https://help.salesforce.com/apex/HTViewSolution?id=000221207

If you have any questions feel free to reach out to me. Thank you!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s